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Abstract

FontForge is an open source program which allows the creation and modification of fonts in many

standard formats. This article will start with the basic problem of converting a picture of a letter

into an outline image (used in most computer fonts). Then I shall describe the automatic creation

of accented characters, and how to add ligatures and kerning pairs to a font, and other advanced

features. Finally I shall present a few tools for detecting common problems in font design.

Résumé

FontForge est un logiciel libre Open Source, permettant la création et la modification de fontes dans
plusieurs formats standard. Dans cet article nous allons d’abord présenter le problème de base de la

conversion d’une image d’une lettre en une image vectorielle. Ensuite nous parlerons de la création

automatique de caractères accentués et de l’adjonction de ligatures et de paires de crénage à une

fonte. Enfin, nous présenterons quelques outils qui permettent de détecter des problèmes fréquents

du processus de création de fonte.

Introduction
FontForge creates fonts, allows you to edit existing fonts,

and can convert from one font format to another.

What is a font? A hundred years ago a font was a collec-

tion of little pieces of metal with the same height and one

design for each of the letters of the alphabet and some

extra symbols like punctuation.

But the world has changed. Fonts are more abstract

now; they are described by data in a computer’s memory.

Three main types of computer fonts are in use today.

F. 1: bitmap, stroked and outline fonts

The simplest font type is a bitmap font. Each char-
acter (actually each glyph) in the font is a tiny little pic-

ture of that character expressed on a rectangular grid of

pixels. This format can provide the best quality font pos-

sible with each glyph perfectly designed, but there are

∗. Original title: Font Creation with PfaEdit.

two main disadvantages: there needs to be a different de-

sign for each size of the font, and these little pictures end

up requiring a large amount of memory.

The other two formats avoid these problems, but

often require some reduction in output quality.

A stroked font expresses each glyph as a set of stems,
with a line drawn down the center of the stem, and then

the line is drawn (stroked) with a pen of a certain width.

The final type is an outline font. Each glyph is ex-

pressed as a set of contours, and the computer darkens the

area between the contours. This format is a compromise

between the above two: it takes much less space than the

bitmap format, but more space than the stroked format,

and it can provide better looking glyphs than the stroked

format but not as nice as the bitmap format. It makes

greater demands on the computer, however, as we shall

see when we discuss hints, later on.

What is a character? And a glyph? A character is an ab-

stract concept: the letter “A” is a character, while any

particular drawing of that character is a glyph. In many

cases there is one glyph for each character and one char-

acter for each glyph, but not always.

The glyph used for the Latin letter “A” may also be

used for the greek letter “Alpha”, while in Arabic writ-

ing most Arabic letters have at least four different glyphs

(often vastly more) depending on what other letters are

around them.

What is a contour? A contour is just a closed path; each

TUGboat, Volume 24 (2003), No. 3—Proceedings of EuroTEX 2003 531



George Williams

glyph is composed of contours. Usually this path is com-

posed of several curved segments called splines. Each

spline is defined by two end points and either 0, 1 or

2 control points which determine how the spline curves.

The more control points a spline has, the more flexible

it can be.

F. 2: splines with 0, 1 and 2 control points

Font creation
You can create an empty font either by invoking Font-

Forge with the -new argument on the command line

$ fontforge -new

or by invoking the New item from the File menu. In

either case you should end up with a window like this:

F. 3: A newly created blank font

Such a font will have no useful name as yet, and will

be encoded with the default encoding (usually Latin1).

Use the Element -> Font Info menu item to correct

these deficiencies. This dialog has several tabbed sub-

dialogs; the first one allows you to set the font’s various

names (see fig. 4):

• the family name (most fonts are part of a family of

similar fonts)

• the font name, a name for PostScript, usually con-

taining the family name and any style modifiers

• and finally a name that is meaningful to humans

If you wish to change the encoding (to TEX Base or

Adobe Standard perhaps) the Encoding tab will present

you with a pulldown list of known encodings. If you are

making a TrueType font then you should also go to the

General tab and select an em-size of 2048 (the default
coordinate system for TrueType is a little different from

that of PostScript).

F. 4: Font name information

Character creation
Once you have done that you are ready to start editing

characters; for the sake of example, let’s create a capital

‘C’. Double click on the entry for “C” in the font view

above (fig. 3). You should now have an empty Outline

Character window (fig. 5).

The outline character window contains two palettes

snuggled up on the left side of the window. The top

palette contains a set of editing tools, and the bottom

palette controls which layers of the window are visible

or editable.

The foreground layer contains the outline that will

become part of the font. The background layer can con-

tain images or line drawings that help you draw this par-

ticular character. The guide layer contains lines that are

useful on a font-wide basis (such as a line at the x-height).

To start with, all layers are empty.

This window also shows the character’s internal co-

ordinate system with the x and y axes drawn in light

grey. A line representing the character’s advance width

is drawn in black at the right edge of the window. Font-

Forge assigns a default advance width of one em (in Post-

Script that will usually be 1000 units) to a new character.

Select the File -> Import menu command to im-

port an image of the character you are creating, assuming
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F. 5: An empty character

that you have one. It will be scaled so that it is as high

as the em-square. In this case that’s too big and we must

rescale the image (fig. 6) as follows.

Make the background layer editable (by selecting

the Back checkbox in the layers palette), move the mouse
pointer to one of the edges of the image, hold down

the shift key (to constrain the rescale to the same pro-

portion in both dimensions), depress and drag the cor-

ner until the image is a reasonable size. Next move the

mouse pointer onto the dark part of the image, depress

the mouse and drag the image to the correct position.

F. 6: Background image

If you have installed the potrace or autotrace pro-

gram you can invoke Element -> AutoTrace to gener-

ate an outline from the image; you should probably fol-

low this by Element -> Add Extrema and Element ->

Simplify. But I suggest you refrain from autotracing,

and trace the character yourself (results will be better).

Change the active layer back to foreground (in the

layers palette), and select the curve point tool from the

tools palette (third from the top of the tools palette, on

the left; the icon is a curve running through a circle).

Then move the pointer to the edge of the image and add

a point. I find that it is best to add points at places where

the curve is horizontal or vertical, at corners, or where

the curve changes inflection. (A change of inflection oc-

curs in a curve like “S” where the curve changes from

being open on the left to being open on the right.) If you

follow these rules hinting will work better.

F. 7: Tracing 1: beginning

It is best to enter a curve in a clockwise fashion, so

the next point should be added up at the top of the image

on the flat section. Because the shape becomes flat here,

a curve point is not appropriate, rather a tangent point is

(the icon on the tools palette is the next one down, with

a little triangle). A tangent point makes a nice transition

from curves to straight lines because the curve leaves the

point with the same slope the line had when it entered.

F. 8: Tracing 2: tangent point

At the moment this “curve” doesn’t match the im-

age at all. Don’t worry about that, we’ll fix it later; and

anyway it will change on its own as we continue. Note

that we now have a control point attached to the tan-

gent point (the little blue x). The next point needs to

go where the image changes direction abruptly. Neither

a curve nor a tangent point is appropriate here, instead
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we must use a corner point (the icon on the tools palette

with the little square).

F. 9: Tracing 3: corner point

As you can see, the curve now starts to follow the

image a bit more closely; we continue adding points until

we are ready to close the path.

F. 10: Tracing 4: continuing

We close the path just by adding a new point on top

of the old start point.

F. 11: Tracing 5: closing the curve

Now we want to make the curve track the image

more closely; to do this, we must adjust the control points

(the blue “x”es). To make all the control points visi-

ble select the pointer tool and double-click on the curve.

Then move the control points around until the curve

looks right.

Finally we set the advance width. Again with the

pointer tool, move the mouse to the width line on the

F. 12: Tracing 6: make it look right

right edge of the screen, depress and drag the line back

to a reasonable location.

And we are done with this character.

Navigating to characters
The font view provides one way of navigating around the

characters in a font. Simply scroll around it until you find

the character you need and then double click to open a

window looking at that character.

Typing a character will move to that character.

But some fonts are huge (Chinese, Japanese and Ko-

rean fonts have thousands or even tens of thousands of

characters) and scrolling around the font view is an inef-

ficient way of finding your character. View -> Goto pro-
vides a simple dialog which will allow you to move di-

rectly to any character for which you know the name (or

encoding). If your font is a Unicode font, then this dia-

log will also allow you to find characters by block name

(e.g. there is a pull-down list from which you may select

Hebrew rather than Alef ).

The simplest way to navigate is just to go to the next

or previous glyph. And View -> Next Glyph and View
-> Prev Glyph will do exactly that.

Loading background images better
In the background image of the previous example the

bitmap of the letter filled the canvas of the image (with

no white borders around it). When FontForge imported

the image it needed to be scaled once in the program.

But usually when you create the image of the letter you

have some idea of how much white space there should be

around it. If your images are exactly one em high then

FontForge will automatically scale them to be the right

size. So in the following examples all the images have ex-

actly the right amount of white space around them to fit

perfectly in an em.

FontForge also has the ability to import an entire

bitmap font (for example a “pk” or “gf” font produced by

METAFONT or the “bdf” format developed by Adobe

for bitmaps) to provide properly scaled background im-

ages for all characters in a font.
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Creating the letter “o”— consistent directions
Let us turn our attention to the letter “o” which has a

hole (or counter) in the middle. Open the outline view

for the letter “o” and import a background image into it.

F. 13: Tracing o

Notice that the first outline is drawn clockwise and

the second counter-clockwise. This change in drawing

direction is important. Both PostScript and TrueType

require that the outer boundary of a character be drawn

in a certain direction (they happen to be opposite from

each other, which is a mild annoyance); within FontForge

all outer boundaries must be drawn clockwise, while all

inner boundaries must be drawn counter-clockwise.

If you fail to alternate directions between outer and

inner boundaries you may get results like the one on the

left: . If you fail to draw the outer contour in

a clockwise fashion the errors are more subtle, but will

generally result in a less pleasing result when the charac-

ter is rasterized.

Technical and confusing: the exact behavior of ras-
terizers varies. Early PostScript rasterizers used a “non-

zero winding number rule” while more recent ones use

an “even-odd” rule. TrueType uses the “non-zero” rule.

The example given above is for the “non-zero” rule. The

“even-odd” rule would fill the “o” correctly no matter

which way the paths were drawn (though there would

probably be subtle problems with hinting).

To determine whether a pixel should be set using

the even-odd rule, draw a line from that pixel to infin-

ity (in any direction) and count the number of contour

crossings. If this number is even the pixel is not filled.

If the number is odd the pixel is filled. Using the non-

zero winding number rule, the same line is drawn, con-

tour crossings in a clockwise direction add 1 to the cross-

ing count, while counter-clockwise contours subtract 1.

If the result is 0 the pixel is not filled; any other result

will fill it.

The command Element -> Correct Direction
looks at each selected contour, figures out whether it

qualifies as an outer or inner contour and reverses the

drawing direction when the contour is drawn incorrectly.

Creating letters with consistent stem widths,
serifs and heights
Many Latin (and Greek and Cyrillic, LGC for short)

fonts have serifs, that is, special terminators at the end

of stems. And in almost all LGC fonts there should only

be a small number of stem widths (i.e. the vertical stem

of “l” and “i” should probably be the same).

FontForge does not have a good way to enforce con-

sistency, but it does have various commands to help you

check for it, and to find discrepancies.

Let us start with the letter “l” and go through the fa-

miliar process of importing a bitmap and defining its out-

line.

F. 14: Beginning “l”

Use the magnify tool to examine the bottom serif,

and note that it is symmetric left to right.

F. 15: Magnified “l”

Trace the outline of the right half of the serif:

F. 16: Half traced “l”

Select the outline, invoke Edit -> Copy, then Edit ->
Paste; then invoke Element -> Transform and select

Flip (from the pull down list) and check Horizontal.
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F. 17: Pasted “l”

Drag the flipped serif over to the left until it snug-

gles up against the left edge of the character:

F. 18: Dragged “l”

Deselect the path, and select one end point and drag

it until it is on top of the end point of the other half.

F. 19: Joining “l”

Finish off the character.

F. 20: Finished “l”

But there are two more things we should do. First

let’s measure the stem width, and second let’s mark the

height of the “l”.

Select the ruler tool from the tool palette, and drag

it from one edge of the stem to the other. A little win-

dow pops up showing the width is 58 units, the drag di-

rection is 180 degrees, and the drag was -58 units hori-

zontally, and 0 units vertically.

F. 21: Measuring stem width

Go to the layers palette and select the Guide radio

box (this makes the guide layer editable). Then draw a

line at the top of the “l”. This line will be visible in all

characters and marks the ascent height of this font.

F. 22: Making a guideline

The “i” glyph looks very much like a short “l” with

a dot on top. So let’s copy the “l” into the “i”; this will

automatically give us the right stemwidth and the correct

advance width

The copy may be done either from the font view

(by selecting the square with the “l” in it and pressing

Edit -> Copy) or from the outline view (by Edit ->
Select All and Edit -> Copy). Similarly, the Paste

may be done either in the font view (by selecting the

“i” square and pressing Edit -> Paste) or the outline

view (by opening the “i” character and pressing Edit ->
Paste).

Now, import the “i” image, and copy and paste the

“l” glyph.

F. 23: Import “i”
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Select the top serif of the outline of the l and drag

it down to the right height:

F. 24: Correcting “i”

Go to the guide layer and add a line at the x-height:

F. 25: Making another guideline

Looking briefly back at the “o” we built before, you

may notice that it reaches a little above the guideline we

put in to mark the x-height (and a little below the base-

line). This is called the overshoot or o-correction, and is

an attempt to remedy an optical illusion. A curve actually

needs to rise about 3% of its diameter above the x-height

for it to appear on the x-height.

F. 26: Comparing “o” to guidelines

Continuing in this manner we can produce all the

base glyphs of a font.

Hints
At small point sizes on display screens, computers often

have a hard time figuring out how to convert a glyph’s

outline into a pleasing bitmap to display. The font de-

signer can help the computer out here by providing what

are called hints.
Basically every horizontal and vertical stem in the

font should be hinted. FontForge has a command

Element -> Autohint which should do this automati-

cally. Or you can create hints manually— the easiest

way is to select two points on opposite sides of a stem

and then invoke Hints -> Add HHint or Hints -> Add
VHint respectively for horizontal or vertical stems.

F. 27: “o” with hints

Accented letters
Latin, Greek and Cyrillic all have a large complement of

accented characters. FontForge provides several ways to

build accented characters out of base characters.

The most obvious mechanism is simple copy and

paste: Copy the letter “A” and Paste it to “Ã”; then

Copy the tilde accent and Paste it Into “Ã”. (N.B.

Paste Into is subtly different from Paste. Paste
clears out the character before pasting, while Paste
Into merges the clipboard into the character, retaining

the old contents.) Then open up “Ã” and position the

accent so that it appears properly centered over the A.

This mechanism is not particularly efficient; if you

change the shape of the letter “A” you will need to re-

generate all the accented characters built from it. To al-

leviate this, FontForge has the concept of a Reference

to a character. Thus, you can Copy a Reference to

“A”, and Paste it, then Copy a Reference to tilde and
Paste it Into, and then again adjust the position of

the accent over the A.
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Then if you change the shape of the A the shape of

the A in “Ã” will be updated automagically— as will the

width of “Ã”.

But FontForge knows that “Ã” is built out of “A”

and the tilde accent, and it can easily create your ac-

cented characters itself by placing the references in “Ã”

and then positioning the accent over the “A”. (Unicode

provides a database which lists the components of every

accented character (in Unicode)). Select “Ã”, then apply

Element -> Build -> Build Accented and FontForge
will create the character by pasting references to the two

components and positioning them appropriately.

FontForge has a heuristic for positioning accents—

most accents are centered over the highest point of the

character—but sometimes this will produce bad results

(e.g. if the one of the two stems of “u” is slightly taller

than the other the accent will be placed over that stem,

rather than being centered over the character), so you

should be prepared to look at your accented characters af-

ter creating them. You may need to adjust one or two (or

you may need to redesign your base characters slightly).

Ligatures
One of the great drawbacks of the standard Type 1 fonts

from Adobe is that none of them come with “ff” liga-

tures. Lovers of fine typography tend to object to this.

FontForge can help you overcome this flaw (whether it

is legal to do so is a matter you must settle by reading the

license agreement for your font). FontForge cannot cre-

ate a nice ligature for you, but what it can do is put all

the components of the ligature into the character with

Element -> Build -> Build Composite. This makes

it slightly easier (at least in Latin) to design a ligature.

Use the Element -> Char Info dialog to name the
character; we’ll use “ffi” as an example. This is a stan-

dard name and FontForge recognizes it as a ligature con-

sisting of f, f and i. Apply Element -> Default ATT
-> Common Ligatures so that FontForge will store the
fact that it is a ligature. Then use Element -> Build
-> Build Composite to insert references to the ligature
components.

F. 28: ffi made of references

Use Edit -> Unlink References to turn the ref-
erences into a set of contours.

F. 29: ffi without references

Adjust the components so that they will look better

together. Here the stem of the first f has been lowered.

F. 30: ffi adjusted

Use Element -> Remove Overlap to clean up the
character.

F. 31: ffi cleaned up
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Some word processors will allow the text editing

caret to be placed inside a ligature (with a caret position

between each component of the ligature). This means

that the user of that word processor does not need to

know s/he is dealing with a ligature and sees behavior

very similar to what s/he would see if the components

were present. But for the word processor to be able to

do this, it must have some information from the font de-

signer giving the appropriate locations of caret positions.

As soon as FontForge notices that a character is a lig-

ature it will insert enough caret location lines into it to

fit between the ligature’s components. FontForge places

these on the origin, and if you leave them there Font-

Forge will ignore them. But once you have built your lig-

ature you might want to move the pointer tool over to the

origin line, press the button and move the caret lines to

their correct locations. (Only AAT and OpenType sup-

port this).

F. 32: ffi with ligature carets

Metrics
Once you have created all your glyphs, you should pre-

sumably examine them to see how they look together.

There are three commands designed for this:

• Windows -> New Metrics View opens a window

which displays several glyphs at a very large size.

You can change the advance width of each glyph

here to make a more pleasing image.

• File -> Print prints a sample text using the font,

or all the glyphs of the font, or several glyphs one

per page, or several glyphs at a waterfall of point

sizes.

• File -> Display opens a dialog which allows you

to display a sample text in this (or indeed several)

fonts.

Kerning
Even in fonts with the most carefully designed metrics

there are liable to be some character combinations which

look ugly. Some combinations are fixed by building liga-

tures, but most are best approached by kerning the inter-

character spacing for that particular pair.

F. 33: kerning in the Metrics view

In the above example the left image shows the un-

kerned text, the right shows the kerned text. To create a

kerned pair, select the two glyphs, then use Windows ->
New Metrics View and move the mouse to the right-

most character of the pair and click on it, the line (nor-

mally the horizontal advance) between the two should go

green (and becomes the kerned advance). Drag this line

around until the spacing looks nice.

Checking a font for common problems
After you have finished making all the characters in your

font, you should check it for inconsistencies. FontForge

has a command, Element -> Find Problems, which is
designed to find many common problems (as you might

guess).

Simply select all the characters in the font and then

bring up the Find Problems dialog. Be warned though:
Not everything it reports as a problem is a real problem,

some may be an element of the font’s design that Font-

Forge does not expect.

The dialog can search for many types of problems:

• Stems which are close to but not exactly some stan-

dard value.

• Points which are close to but not exactly some stan-

dard height.

• Paths which are almost but not quite vertical or hor-

izontal.

• Control points which are in unlikely places.

• Points which are almost but not quite on a hint.

• and more .. .
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I find it best just to check for a few similar problems at a

time; switching between different types of problems can

be distracting.

Generating a font
The penultimate2 stage of font creation is generating a

font. N.B.: The File -> Save command in FontForge

will produce a format that is only understood by Font-

Forge and is not useful in the real world.

You should use File -> Generate to convert your

font into one of the standard font formats. FontForge

presents what looks like a vast array of font formats, but

in reality there are just several variants on a few basic font

formats: PostScript Type 1, TrueType, OpenType (and

for CJK fonts, also CID-keyed fonts) and SVG.

OpenType advanced typography
In OpenType and Apple’s Advanced Typography fonts it

is possible for the font to know about certain common

glyph transformations and provide information about

them to a word processor using that font (which presum-

ably could then allow the user access to them).

Simple substitutions Suppose that we had a font with sev-
eral sets of digits: monospaced digits, proportional dig-

its and lower case (old style) digits. One of these styles

would be chosen to represent the digits by default (say

the monospaced digits). Then we could link the default

glyphs to their variant forms.

First we should name each glyph appropriately

(proportional digits should be named “zero.fitted”, “one.

fitted”, and so forth, while oldstyle digits should be

named “zero.oldstyle”, “one.oldstyle”, and so forth. Use

the Element -> Glyph Info command to name them.

F. 34: Naming a glyph

2. The final stage of font creation would be installing the font.
This depends on what type of computer you use and I shan’t at-
tempt to describe all the possibilities here.

To link the glyphs together we invoke Element ->
Glyph Info again, this time on the default glyph and

select the Subs tab. This provides a list of all simple sub-
stitutions defined for this glyph.

F. 35: Providing substitutions

Pressing the [New] button will allow you to add a

substitution:

F. 36: Editing substitutions

Each substitution must contain: the name of a glyph

to which it is to be mapped, a four-character OpenType

tag used to identify this mapping, and a script and lan-

guage in which this substitution is active. There is a pull-

down menu which you can use to find standard tags for

some common substitutions (the tag for oldstyle digits is

‘onum’). This substitution is for use in the Latin script

and for any language; again there is a pulldown menu to

help choose this correctly.

Contextual substitutions OpenType and Apple also pro-

vide contextual substitutions. These are substitutions

which only take place in a given context and are essen-

tial for typesetting Indic and Arabic scripts.

In OpenType a context is specified by a set of pat-

terns that are tested against the glyph stream of a docu-

ment. If a pattern matches, then any substitutions it de-

fines will be applied.

Instead of an Indic example, let us take something

I’m more familiar with, the problem of typesetting a
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Latin script font where the letters “b”, “o”, “v”, and

“w” join their following letter near the x-height, while

all other letters join near the baseline.

Thus we need two variants for each glyph, one that

joins (on the left) at the baseline (the default variant) and

one which joins at the x-height. Let us call this second

set of letters the “high” letters and name them “a.high”,

“b.high”, and so forth.

F. 37: Incorrect & correct script joins

We divide the set of possible glyphs into three

classes: the letters “bovw”, all other letters, and all other

glyphs. We need to create two patterns; the first will

match a glyph in the “bovw” class followed by a glyph

in the “bovw” class, while the second will match a glyph

in the “bovw” class followed by any other letter. If either

of these matches the second glyph should be transformed

into its high variant.

The first thing we must do is create a simple sub-

stitution mapping for each low letter to its high variant.

Let us call this substitution by the four character Open-

Type tag “high”. We use Element -> Glyph Info as

before except that here we use the special “script/lan-

guage” called “—Nested—” (an option in the pull-

down menu).

The tricky part is defining the context. This is

done with the Contextual tab in the Element -> Font
Info dialog, revealing five different types of contextual

behavior. We are interested in contextual chaining sub-

stitutions.

F. 38: Font Info showing Contextual Subs

You can add a new entry by pressing the [New] but-
ton. This brings up a series of dialogs. The first re-

quests a four character OpenType tag and a script/lan-

guage, much as we saw earlier. The next dialog allows

you to specify the overall format of the substitution.

F. 39: Tag & Script dialog and format of

contextual chaining substitution

The next dialog finally shows something interesting.

At the top are a series of patterns to match and substitu-

tions that will be applied if the string matches. Under-

neath that are the glyph classes that this substitution uses.

F. 40: Overview of the contextual chaining

substitution

A contextual chaining dialog divides the glyph

stream into three categories: those glyphs before the cur-

rent glyph (these are called backtracking glyphs), the cur-

rent glyph itself (you may specify more than one, and this

(these) glyph(s) may have simple substitutions applied to

them), and finally glyphs after the current glyph (these

are called lookahead glyphs).

Each category of glyphs may divide glyphs into a

different set of classes, but in this example we use the
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same classes for all categories (this makes it easier to con-

vert the substitution to Apple’s format).

The first line (in the “Lists of lists” field) should be

read thus: If a backtracking glyph in class 1 is followed

by a match glyph in class 2, then location 0 in the match

string (that is, the first glyph) should have the simple sub-

stitution ‘high’ applied to it. If you look at the glyph class

definitions you will see that class 1 includes those glyphs

which must be followed by a high variant, so this seems

reasonable.

The second line is similar except that it matches

glyphs in class 1. Looking at the class definitions we see

that classes 1 & 2 include all the letters, so these two lines

mean that if any letter follows one of “bovw” then that

letter should be converted to its ‘high’ variant.

To edit a glyph class, double click on it. To create

a new one press the [New] button (under the class list).

F. 41: Editing glyph classes

This produces another dialog showing all the names

of all the glyphs in the current class. Pressing the

[Select] button will set the selection in the font win-

dow to match the glyphs in the class, while the [Set]
button will do the reverse and set the class to the selec-

tion in the font window. These provide a shortcut to typ-

ing in a lot of glyph names. Pressing the [Next] button
defines the class and returns to the overview dialog.

To edit a pattern double click on it, or to create a

new one press the [New] button (under “Lists of lists”).
Again the pattern string is divided into three cat-

egories, those glyphs before the current one, the cur-

rent one itself, and any glyphs after the current one. You

choose which category of the pattern you are editing with

the tabs at the top of the dialog. Underneath these is the

subset of the pattern that falls within the current cate-

gory, the classes defined for this category, and finally the

substitutions for the current glyph(s). Clicking on one of

the classes will add the class number to the pattern.

To edit a substitution double click on it, or to create

a new one press the [New] button (under “An ordered

list . . .”). The sequence number specifies which glyph

among the current glyphs should be modified, and the

tag specifies a four character substitution name.

F. 42: Adding matches and substitutions

Apple advanced typography
Some of Apple’s typographic features can be readily con-

verted into equivalent OpenType features, while others

cannot be.

Non-contextual ligatures, kerning and substitutions

can generally be converted from one format to another.

Apple uses a different naming convention and defines a

different set of features, but as long as a feature of these

types is named in both systems, conversion is possible.

Contextual substitutions Apple specifies a context with a
finite state machine, which is essentially a tiny program

that looks at the glyph stream and decides what substitu-

tions to apply.

Each state machine has a set of glyph class definitions

(just as in the OpenType example), and a set of states.

The process begins in state 0 at the start of the glyph

stream. The computer determines what class the current

glyph is in and then looks at the current state to see how

it will behave when given input from that class. The be-

havior includes the ability to change to a different state,

advancing the input to the next glyph, applying a substi-

tution to either the current glyph or a previous one (the

“marked” glyph).

Using the same example of a Latin script font . . .

We again need a simple substitution to convert each

letter into its high alternate. The process is the same as

it was for OpenType, and indeed we can use the same

substitution.

Again we divide the glyphs into three classes (Apple

gives us some extra classes whether we want them or not,

but conceptually we use the same three classes as in the

OpenType example). We want a state machine with two

states (again Apple gives us an extra state for free, but we

shall ignore that); one is the start state (the base state,
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where nothing changes), and the other is the state where

we’ve just read a glyph from the “bovw” class.

F. 43: State machine

Again we use the Element -> Font Info dialog

and the Mac SM tag to look at the contextual substitutions
available. Again there are several types of contextual be-

havior, and we are interested in contextual substitutions.

F. 44: Font Info showing State Machines

Double clicking on a state machine, or pressing the

[New] button provides an overview of the given state ma-

chine. At the top of the dialog we see a field specifying

the feature/setting of the machine; this is Apple’s equiv-

alent of the OpenType four-character tag. Under this is

a set of class definitions, and at the bottom is a represen-

tation of the state machine itself. See fig. 45.

Double clicking on a class brings up a dialog similar

to that used in OpenType:

F. 46: Editing Apple glyph classes

F. 45: Overview of a State Machine

Clicking on a transition in the state machine (there

is a transition for each state/class combination) produces

a transition dialog.

This controls how the state machine behaves when

it is in a given state and receives a glyph in a given class.

In this example it is in state 2 (which means it has already

read a “bovw” glyph), and it has received a glyph in class

4 (which is another “bovw” glyph). In this case the next

state will be state 2 again (we will have just read a new

“bovw” glyph), read another glyph and apply the “high”

substitution to the current glyph.

At the bottom of the dialog is a series of buttons that

allow you to navigate through the transitions of the state

machine.

F. 47: Transition dialog

Pressing [OK]many times will extract you from this

chain of dialogs and add a new state machine to your font.
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Appendix: Additional features
FontForge provides manymore features, further descrip-

tions of which may be found at

http://fontforge.sf.net/overview.html
Here is a list of some of the more useful of them:

• Users may edit characters composed of either third

order Bézier splines (for PostScript fonts) or second

order Béziers (for TrueType fonts) and may convert

from one format to another.

• FontForge will retain both PostScript and True-

Type hints, and can automatically hint PostScript

fonts.

• FontForge allows you to modify most features of

OpenType’s GSUB, GPOS and GDEF tables, and

most features of Apple’s morx, kern, lcar and prop

tables. Moreover it can often convert from one for-

mat to another.

• FontForge has support for Apple’s font formats. It

can read and generate Apple font files both on and

off a Macintosh. It can generate the FOND resource

needed for the Mac to place a set of fonts together

as one family.

• FontForge allows you to manipulate bitmap fonts as

well as outline fonts. It has support for many for-

mats of bitmap fonts (including TrueType’s embed-

ded bitmaps—both the format prescribed by Ap-

ple and that specified by Microsoft).

• FontForge can interpolate between two fonts (sub-

ject to certain constraints) to yield a third font be-

tween the two (or even beyond). For instance given

a “Regular” and a “Bold” variant it could produce a

“DemiBold” or even a “Black” variant.

• FontForge also has a command (which often fails

miserably) which attempts to change the weight of

a font.

• FontForge can automatically guess at widths for

characters, and even produce kerning pairs automat-

ically.

• FontForge has some support for fonts with verti-

cal metrics (in Japanese, Chinese and Korean fonts),

and some support for right to left fonts (Arabic, He-

brew, Linear-B, etc.).

• FontForge has some support for PostScript (and

pdf ) Type 3 fonts, allowing for glyphs with differ-

ent strokes and fill and images.

• FontForge has a scripting language which allows

batch processing of many fonts at once.
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